8th April 2019

Issue with 2010 exchange server not responding

Issue with 2010 Exchange server not responding, we are investigating the problem